Написать программу в паскале 1.вычислить сумму и произведение n первых членов арифметической прогрессии: а1=2; d=3; an=an-1+d. 2,дано натуральное число n. вычислить (1+1/12)(1+1/22) … (1+1/n2). 3.дано целое число а. найти произведение целых чисел из промежутка от 1 до а

evmenovvlad evmenovvlad    3   09.08.2019 16:40    37

Ответы
elenastennikova elenastennikova  04.10.2020 07:40
1) 
var a,s,p,n,i:integer;

begin
readln(n);
s:=0; p:=1; a:=2;
for i:=1 to n do begin
p:=p*a;
s:=s+a;
a:=a+3;
end;
writeln(s,' 'p);
end.

2)

3)var a,p,i:integer;
begin
readln(a);
p:=1;
for i:=1 to a do
p:=p*i;
writeln(p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика