Составить программу, используя одномерные массивы: Дан массив А (15). Сформировать новый
массив из отрицательных чисел исходного массива.​
(Pascal)

DekenS1 DekenS1    3   28.01.2021 00:18    5

Ответы
RPkhf RPkhf  27.02.2021 01:27

var

 a, b: array[1..15] of integer;

 i, k: integer;

begin

 randomize;

 k := 1;

 WriteLn('Массив:');

 for i := 1 to 15 do

 begin

   a[i] := random(200) - 100;

   Write(a[i], ', ');

   if a[i] < 0 then

   begin

     b[k] := a[i];

     inc(k);

   end;

 end;

 WriteLn;

 WriteLn('Новый массив:');

 for i := 1 to k - 1 do Write(b[i], ', ');

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика