Решить на c#, используя циклы. составить программу для вычисления и вывода n первых чисел фибоначчи. числа фибоначчи получаются с следующих рекуррентных соотношений где - целое. отследить корретность ввода исходных данных.

dianamuk20067 dianamuk20067    1   21.05.2019 19:20    2

Ответы
Kartakova Kartakova  01.10.2020 04:47

using System;

class Program
{
public static int Fibonacci(int n)
{
int a = 0;
int b = 1;
for (int i = 0; i < n; i++)
{
int temp = a;
a = b;
b = temp + b;
}
return a;
}

static void Main()
{
Console.Write("Введите N:");
int n = Int32.Parse(Console.ReadLine());
for (int i = 0; i < n; i++)
{
Console.WriteLine(Fibonacci(i));
}
}
}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы