Составить программу, используя двумерные массивы: Найти сумму нечетных
цифр строки у которого второй элемент больше
первого.
(Pascal)​

Fancyone Fancyone    1   28.01.2021 00:27    4

Ответы
LuсКу LuсКу  27.02.2021 00:27

var

 a: array[,] of integer;

 m, n, i, j, k, sum: integer;

begin

 Write('Введите размер матрицы M и N: '); ReadLn(m, n);

 SetLength(a, m, n);

 randomize;

 k := - 1;

 WriteLn('Массив:');

 for i := 0 to m - 1 do

 begin  

   for j := 0 to n - 1 do

   begin

     a[i, j] := random(100);

     Write(a[i, j]:4);

   end;

   WriteLn;

 end;

 for i := 0 to m - 1 do

    if (a[i, 1] > a[i,0]) and (k = -1) then k := i;

 if k = -1 then

 begin

   WriteLn('Нет строк, у которых второй элемент больше первого');

   exit;

 end;

 for j := 0 to n - 1 do

    if (a[k, j] mod 2 = 1) then sum := sum + a[k, j];

 WriteLn('Сумма нечетных чисел строки, у которой второй элемент больше первого, равна ', sum);

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика