ЗАДАЧА C++ Напишите программу, которая считывает число x, а затем пишет его, поставив перед ним х пробелов
Формат входных данных
Целое не отрицательное число x (Гарантируется, что x не меньше нуля и не больше 9)
Формат выходных данных
Число x, перед которым стоит x пробелов.

Ganster1234567 Ganster1234567    2   05.12.2020 00:56    12

Ответы
дывавып дывавып  04.01.2021 00:56

#include <iostream>

using namespace std;

int main() {

   int x;

   cin >> x;

   for (int i = 0; i < x; i++) cout << " ";

   cout << x;

}

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
RFTBOY RFTBOY  04.01.2021 00:56

#include <iostream>

using namespace std;

int main()

{

setlocale(LC_CTYPE,"Russian");

int x;

cin >>x;

if(x>0 && x<9)

{

for(int i= 0; i<x; i++)

{

cout << " ";

}

cout<<x;

}

else cout<<"Число х не соответсвует диапазону";

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика