tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу, решающую
Составить программу, решающую следующую : возраст коли – x лет, а возраст миши – y лет. найти их средний возраст, а также определить, на сколько возраст одного мальчика отличается от возраста другого.
Miratovich
2 06.06.2019 04:10
11
Ответы
146727
06.07.2020 12:04
#include <iostream>
using namespace std;
int main(){
int a,s,d,f;
setlocale(0,"");
cout<<endl<<"Введите возраст Коли:";
cin>>a;
cout<<endl<<"Введите возраст Миши:";
cin>>s;
if (a>s && a>0 && s>0) {
d=a-s; f=(a+s)/2;
cout<<endl<<"Коля старше Миши на: "<<d<<" лет"<<endl;
cout<<"Средний возраст ребят: "<<f<<" лет"<<endl;
}
if (a<s && a>0 && s>0) {
d=s-a; f=(a+s)/2;
cout<<endl<<"Миша старше Коли на: "<<d<<" лет"<<endl;
cout<<endl<<"Средний возраст ребят: "<<f<<" лет"<<endl;
}
if (a<0 || s<0) {
cout<<endl<<"Вы ввели отрицательное число"<<endl;
}
system ("pause");
return 0;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Рикания
23.06.2019 15:00
Значения элементов двумерного массива а размером 5x5 с вложенного цикла в представленном фрагменте программы: паскаль алгоритмический язык for i: =1 tо 5 do for j: =1 tо 5 do...
tvzhanna80
07.08.2019 15:00
Что закодировано следующей последовательностью двоичных кодов? 00110110 00101011 00110111 00111101 00110001 00110011...
Aikony
09.04.2019 19:34
Написать программу для решения : ввести элементы массива а, состоящего из 11 целых элементов, вывести элементы квадраты элементов массива, стоящих на четных местах, в обратном...
Ларкия
30.07.2019 01:10
Каких объемов может достигать память винчестера(жестких)?...
tailurs
30.07.2019 01:10
Даны сторона квадрата и радиус окружности. составить программу определяющую у какой фигуры площадь больше...
ajamshid1976p042ct
11.09.2019 04:20
Таблица достоинства и недостатки твёрдотельного накопителя....
vi600081
11.09.2019 04:20
Напишите программу на языке pascalabc.net которая с алгоритма евклида вычисляет нод....
ulaklimenko49
11.09.2019 04:20
13б сколько строк напечатает программа: var k,l: integer; begin k: =8; while k 0 do begin l: =10; while l 15 do begin writeln( мне нравится паскаль. ); l: =l+1; end; k: =k-1;...
Ромчик55123
10.10.2019 20:57
4. выскажи свое мнение,прочитай о семейных правилах саната. согласен ли ты с ними? выпишислова действия множественного числа.вышемы любим друг друга.делаем полезные дела.вместе...
UNDEADrevolution
10.10.2019 20:57
№2. родители и двое детей поспорили, на кого из них распространяется трудовое законодательство . отец - военнослужащий ; мать – преподаватель в средней школе; сын – индивидуальный...
Популярные вопросы
по истории Казахстана быстрее!!...
2
Написать и оформить свое рекламное объявление для места проведения отдыха....
1
Напишите ЭССЕ на тему Органическая химия для меня... Опишите, что для вас...
2
Реки Евразии относятся к бассейнам всех 4 океанов планеты. Докажите это конкретными...
2
решите этот пример В каком случае не будет равно нулю?...
2
помагите последние задание...
3
Завершите предложения настоящим и Используйте следующие глаголы (не строить,...
3
Самые рас вещи найденные Сарматских погребах....
3
Что послужило главной причиной образования многочисленных полезных ископаемых...
3
Двухзначное число на 9 больше своей суммы цифр. Найдите это число если его...
3
using namespace std;
int main(){
int a,s,d,f;
setlocale(0,"");
cout<<endl<<"Введите возраст Коли:";
cin>>a;
cout<<endl<<"Введите возраст Миши:";
cin>>s;
if (a>s && a>0 && s>0) {
d=a-s; f=(a+s)/2;
cout<<endl<<"Коля старше Миши на: "<<d<<" лет"<<endl;
cout<<"Средний возраст ребят: "<<f<<" лет"<<endl;
}
if (a<s && a>0 && s>0) {
d=s-a; f=(a+s)/2;
cout<<endl<<"Миша старше Коли на: "<<d<<" лет"<<endl;
cout<<endl<<"Средний возраст ребят: "<<f<<" лет"<<endl;
}
if (a<0 || s<0) {
cout<<endl<<"Вы ввели отрицательное число"<<endl;
}
system ("pause");
return 0;}