Напишите программу, которая находит сумму двузначных нечётных чисел в последовательности целых чисел. программа получает на вход це¬лые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: сумму двузначных нечётных чисел в последовательности. входные данные: 11, 15, 30, 9, 0 выходные данные: 26.

mintoo0 mintoo0    2   27.08.2019 16:40    8

Ответы
слядя слядя  05.10.2020 23:04
Решение фактически в один оператор

// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln(ReadSeqIntegerWhile(n->n<>0)
      .Where(n->n.IsOdd and (n>=10) and (n<=99)).Sum)
end.
ПОКАЗАТЬ ОТВЕТЫ
ЛизаБугакова ЛизаБугакова  05.10.2020 23:04
Var
   A:integer;
   S:real;
Begin
S:=0;
Repeat
Read(A);
if (9<Abs(A))and(Abs(A)<100)and(A mod 2 <> 0) then S:=S+A;
Until A=0;
WriteLn(S)
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика