Золото Python Мудрец ходит по комнате размера n×m клеток. В каждой клетке комнаты лежит заданное количество золота. Проходя по клетке мудрец забирает всё золото с неё. Зная план комнаты и маршрут мудреца, посчитайте сколько золота он собрал. В задаче не гарантируется, что мудрец не проходил по одной и той же клетке более одного раза.
Входные данные

Во входных данных описан план комнаты: сначала количество строк n, затем — количество столбцов m (1≤n≤20,1≤m≤20). Затем записано n строк по m чисел в каждой — количество килограммов золота, которое лежит в данной клетке (число от 0 до 50). Далее записано число x — сколько клеток обошел мудрец. Далее записаны координаты этих клеток (координаты клетки — это два числа: первое определяет номер строки, второе — номер столбца), верхняя левая клетка на плане имеет координаты (1,1), правая нижняя — (n,m).

Выходные данные

Выведите количество килограммов золота, которое собрал мудрец.

Примеры
Ввод
3 3
1 2 3
4 5 6
7 8 9
5
1 1
1 2
1 1
1 2
1 1
вывод
3

nazar94 nazar94    3   27.07.2021 09:39    244

Ответы
2MaRiIa2 2MaRiIa2  26.08.2021 10:24

rows, cols = map(int, input().split())

room = [map(int, input().split()) for y in range(rows)]

path_len = int(input())

path = [map(int, input().split()) for i in range(path_len)]

gold = 0

for (row, col) in path:

   gold += room[row - 1][col - 1]

   room[row - 1][col - 1] = 0

 

print(gold)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика