Написать программу на языке Си. Дано целое число N и последовательность, состоящая из N целых чисел. Вывести
сумму чисел из данной последовательности, которые больше своего левого соседа.

Dimka621 Dimka621    1   01.11.2020 11:22    1

Ответы
LyudaDolina LyudaDolina  01.12.2020 11:23

#include <stdio.h>

int main() {

 

int n;

scanf("%d", &n);

 

 

int a, b, tmp, ans = 0;

scanf("%d", &tmp);

for (int i = 1; i < n; i++)

{

 int a;

 scanf("%d", &a);

 if (a > tmp)ans += a;

 tmp = a;

}

printf("%d", ans);

getchar();

getchar();

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика