Написать программу на паскаль: найти произведение наибольших элементов двумерного массива, первый элемент которого отрицателен.

aretem2002 aretem2002    3   07.06.2019 09:10    4

Ответы
alinakuzmich324 alinakuzmich324  07.07.2020 07:10
Если имеется в виду произведение наибольших в каждой строке элементов, то тогда так:
var
   i,j,p:integer;
   max:array[1..5]of integer;
   a:array[1..5,1..5]of integer;
begin
p:=1;
for i:=1 to 5 do
  for j:=1 to 5 do
    a[i,j]:=random(-10,10);
a[1,1]:=random(-10,-1);
for i:=1 to 5 do
  begin
  for j:=1 to 5 do
    begin
    write(a[i,j]:4);
    if a[i,j]>max[i] then max[i]:=a[i,j];
    end;
  p:=p*max[i];
  writeln;
  end;
writeln('P=',p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика