№1 требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и ь хотя бы одно четное. была написана следующая программа: • var a, b: integer; • begin • readln(a, b); • a : = a mod 2; • if a > 0 then b : = b mod 2; • if b > 0 then • writeln ('четных чисел нет') • else • writeln ('четное число есть'); • end. доработайте эту программу таким образом, чтобы решалась верно. №2 с клавиатуры вводится трёхзначное число. нужно вывести ответ «да», если все его цифры четные, и ответ «нет» в остальных случаях. если введено не трёхзначное число, должно быть выведено сообщение «неверное число».

bartosz04 bartosz04    3   10.06.2019 11:20    9

Ответы
илья1988 илья1988  08.07.2020 20:48
N1
var a, b: integer;

•​ begin

•​ readln(a, b);

•​ a := a mod 2;
b := b mod 2;
•​ if (b > 0) and (a > 0) then

•​ writeln ('четных чисел нет')

•​ else

•​ writeln ('четное число есть');
end.

N2

#include <iostream>

using namespace std;

int main()
{
  int a;
  cin >> a;
  if(a < 100 || a > 999) cout  << "Неверное число" << endl;
  else
  {
    int a1 = a/100;
    int a2 = (a/10)%10;
    int a3 = a%10;
    if(a1%2==a2%2==a3%2==0) cout << "Да" << endl;
    else cout << "Нет" << endl;
  }
  return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика