Язык Паскаль. Напишите программу, которая моделирует работу следующего автомата. Автомат получает на вход трехзначное число и строит новое число следующим образом: 1) вычисляются суммы первой и второй, затем - второй и третьей цифр; 2) эти суммы записываются в порядке не возрастания. Например, для числа 639 получаем суммы: 6 + 3 = 9; 3 + 9 = 12. Результат: 129 Напишите программу, которая реализует работу данного автомата

помогите1185 помогите1185    2   26.02.2021 12:28    15

Ответы
инглишер инглишер  28.03.2021 12:29

var N,a,b,c,s1,s2:integer;

begin

Writeln('Напишите трёхзначное число');

ReadLn(N);

a:= N div 100;

b:= N div 10 mod 10;

c:= N mod 10;

s1:= a+b;

s2:= b+c;

if s1<s2 then

write(s2,s1)

else

write(s1,s2);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика