Выведите все элементы массива с: а) нечётными индексами (то есть A[1], A[3], A[5], ...);

б) чётными индексами (то есть A[0], A[2], A[4], ...).

Формат входных данных

Вводится количество элементов в массиве. Далее вводятся элементы массива.

Формат выходных данных

Выведите ответ на задачу.

Sample Input:

5

1

2

3

4

5

Sample Output:

1 3 5

gggggerrrr gggggerrrr    3   22.11.2020 23:40    16

Ответы
mafobe66 mafobe66  22.12.2020 23:42

int[] mas;

int n;  

n = Convert.ToInt32(Console.ReadLine());

mas = new int[n];

for (int i = 0; i < mas.Length; i++)

mas[i] = Convert.ToInt32(Console.ReadLine());

Console.WriteLine();

Console.WriteLine("Элементы с чётными индексами:");

for (int i = 0; i < mas.Length; i = i + 2)

{    

Console.WriteLine(mas[i]);

}

Console.WriteLine();

Console.WriteLine("Элементы с нечётными индексами:");

for (int i = 1; i < mas.Length; i = i + 2)

{

Console.WriteLine(mas[i]);

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика