tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Цикл со счетчиком. представить
Цикл со счетчиком. представить блок-схему и программу. дано два целых положительных числа a и n, вводимых с клавиатуры. найти n^a.
ganjaman007
2 23.06.2019 06:30
2
Ответы
kucharin
19.07.2020 08:18
var a, n, rez, i: integer;
begin
write('Введите a: ');
readln(a);
write('Введите n: ');
readln(n);
if a = 0 then rez := 1
else begin
rez := n;
for i := 1 to y - 1 do rez := rez * n;
end;
writeln(rez);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
екатерина699
21.08.2019 09:10
Как в паскале делать вычитания и умножения?...
dianasmertiyk
25.11.2021 06:24
С Красные плюхри тоже делятся. Но для этого их нужно намазать горчицей. Если намазать жёлтого плюхря горчицей, то утром следующего дня он разделится на два. Утром третьего дня...
maxjk19
25.11.2021 06:24
Напиши программу, которая разделяет запятыми на тройки (считая справа) натуральное число. Программа на вход получает натуральное число.Если в числе менее трёх знаков, то программы...
seterkton
12.01.2021 17:23
написать программу, которая в последовательности натуральных чисел находят max/min выводит его на экран...
ЮляЯяя1111
05.09.2019 15:00
Переведите 1048576 бит в килобайты...
pdv20
05.09.2019 15:00
Какими графическими образами можно проиллюстрировать 1) виды информации; 2) свойства информации....
noname1372321
05.09.2019 15:00
Пример известных вам носителей информации...
даша3648
18.07.2019 08:20
F=pgv написать программу, где p - плотность, g - ускорение свободного падения g: =10, v-объем....
ilham11997766
17.04.2019 06:10
В каком году началась первая Русско-турецкая война в правление Екатерины II?...
Lana8254
17.04.2019 06:10
Как сложилась судьба полководца М.Б. Шеина после поражения в Смоленской войне?...
Популярные вопросы
Из перечисленного: 1) отсутствие четкой границы между грамматикой и лексикой;...
3
По мнению Ю.Д. Дешериева, общественные функции языка обусловливаются ролью...
3
Укажите вид диглоссии, существовавший в средневековой Европе Латинско-национальная...
1
Из перечисленного: 1) английский язык; 2) знаки дорожного движения; 3) календарь;...
1
В основании классификации языков на «здоровые», «больные», исчезающие и «мертвые»...
1
Установите соответствие между понятиями и их определениями диалект < разновидность...
2
Совокупность черт языковой системы, не выводимых из внутренних законов развития...
2
Процесс вербального и невербального общения, постоянно протекающий между людьми...
3
Функциональные отношения между компонентами социально-коммуникативной системы...
1
Национальный язык, с точки зрения внутренней структуры, является наследником...
2
begin
write('Введите a: ');
readln(a);
write('Введите n: ');
readln(n);
if a = 0 then rez := 1
else begin
rez := n;
for i := 1 to y - 1 do rez := rez * n;
end;
writeln(rez);
end.