Впаскале abc написать программу, вычисляющую корни квадратного уравнения (используйте условный оператор для сравнения дискриминанта с нулем)

23774947hhbhut 23774947hhbhut    2   13.07.2019 07:40    1

Ответы
polinazayats0 polinazayats0  18.09.2020 21:17
Var a, b, c, x1, x2, D:real;
begin
writeln ('Введите значение a, b и c');
readln (a, b, c);
D:=sqr(b)-4*a*c;
if D>0 then
begin
x1:=(-b+sqrt(D))/2*a;
x2:=(-b-sqrt(D))/2*a;
writeln ('x1 = ', x1, ' x2 = ', x2)end
else
writeln ('Корней нет');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика