tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Водномерном массиве
Водномерном массиве найти среднее арифметическое элементов массива(написать программу на паскале)
Фара1323
3 26.08.2019 10:20
5
Ответы
пматмг
05.10.2020 20:47
Const N = 50;
Var
A:array[1..N] of integer;
i:integer;
S:real;
Begin
Randomize;
Write('Исходный массив: ');
For i:= 1 to N do
Begin
A[i]:=random(21)-10;
Write(A[i],' ');
S:=S+A[i]
End;
WriteLn;
WriteLn('Sr = ',S/N);
End.
Пример:
Исходный массив: 4 2 -2 -4 -7 7 -9 6 -10 10 -4 -4 -5 3 0 -2 -3 0 -4 9 -1 -4 -2 -4 -9 2 2 -10 -8 -2 -8 -7 6 2 -9 7 2 -10 -10 -4 -9 -7 -2 -10 2 1 -3 6 0 0
Sr = -2.04
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
dragonhar
19.05.2019 05:50
Презентация на тему : реклама товара...
nastyaplokhovanastya
14.07.2019 03:40
Как составить программу, в которой нужно сначала ввести число, а по нему ввести количество данных ? например: вводим: 5 6 7 8 4 3 2 4 5 (строки 6 7 8 4 3 и 4 5 тоже числа, которые...
vladuha691
14.07.2019 03:30
Посчитайте количество букв, соответствующих гласным звукам ( а , я , …), в абзаце из книги л.н. толстого “война и мир”. вскоре после маленькой княгини вошел массивный, толстый молодой...
тиматимуша
14.07.2019 03:30
Нужно написать программу на с++. случайным образом изменить порядок следования тетрад в числе. пример: 0xdeadbeef → 0xeddefabe....
Jora2001Voronov
14.07.2019 03:20
Решите . сколько символов содержит сообщение, записанное с 16ти символьного алфавита, если его объем составил 1/16 часть мбайта....
Kam09
14.07.2019 03:20
Написать программу,. подсчитать сумму ряда -1-2+3+4-5-6+7++n n-вводится пользователем (цикл со счетчиком (for i: =1 to n do))...
alistas
14.07.2019 03:20
Запись числа n в системе счисления с основанием 7 содержит две цифры, запись этого числа в системе счисления с основанием 6 содержит три цифры, а запись в системе счисления с основанием...
damirpernebek7
27.08.2019 09:20
Хорошо ли когда снятся пчёлы и к чему это?...
moldirkenesova
27.08.2019 09:20
Вспомни и запиши как можно больше имён героев и названий предметов из сказок, которые 1) имеют необычный рост 2) имеют необычное количество частей 3) сделаны из необычного материала...
nog2018
27.08.2019 09:20
Выписано несколько последовательных членов прогрессии: 162, х, 18, -6 найти: х ....
Популярные вопросы
Чему равна скорость пороховой ракеты массой 2 килограмм после вылета из нее продуктов...
2
Какая неправильная форма глагола invite...
1
Выпиши слово в котором s не указывает на множественное число и притяжательный...
3
Какие весенние явления в жизни растений?...
1
Выписать из повести м.булгакова собачье сердце не менее 8 словосочетаний на вид...
3
Какие моря и океаны граничат с россией?...
3
Вопрос к слову христиане на к кроссворду...
3
Диктант со словами директор, аллея, фотоаппарат, недоросль росток, профессия...
2
Какова сила давления на парус яхты площадью 60 м2, если давление ветра 80 н/м2....
1
Что означает индивид,индивидуальность...
1
Var
A:array[1..N] of integer;
i:integer;
S:real;
Begin
Randomize;
Write('Исходный массив: ');
For i:= 1 to N do
Begin
A[i]:=random(21)-10;
Write(A[i],' ');
S:=S+A[i]
End;
WriteLn;
WriteLn('Sr = ',S/N);
End.
Пример:
Исходный массив: 4 2 -2 -4 -7 7 -9 6 -10 10 -4 -4 -5 3 0 -2 -3 0 -4 9 -1 -4 -2 -4 -9 2 2 -10 -8 -2 -8 -7 6 2 -9 7 2 -10 -10 -4 -9 -7 -2 -10 2 1 -3 6 0 0
Sr = -2.04