tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Написать программу,. подсчитать
Написать программу,. подсчитать сумму ряда -1-2+3+4-5-6+7++n n-вводится пользователем (цикл со счетчиком (for i: =1 to n do))
Kam09
3 14.07.2019 03:20
3
Ответы
nikvet
03.10.2020 03:38
// PascalABC.NET 3.0, сборка 1138
var
i,n,s:integer;
begin
Write('n='); Read(n);
s:=0;
for i:=1 to n do
if ((i mod 4)=1) or ((i mod 4)=2) then s:=s-i else s:=s+i;
Writeln('Сумма ряда равна ',s)
end.
Тестовое решение:
n=13
Сумма ряда равна -1
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Zan22
20.04.2021 08:42
1.исполненияПрограммирование на языке PascalВариант 1Задание Определите значениепеременной а последанного алгоритма:а:= 36b:= а12b:= b+a/4а:=a /ь* 3В ответе укажите...
zozoshcka17
20.04.2021 08:42
проверить,имеется ли в данном массиве Y(10) хотя бы одна пара чисел ,совпадающих по величине .Создать ,две функции, одна функция заполняет его с клавиатуры.Другая...
Reshebnikov
20.04.2021 08:41
Что означает понятие анимации?Какие блоки используются для создания анимации?Что означает цвета блоков?Что такое скрипт?Как запустить проект?Котенок достиг нижнего...
Indira6767
20.04.2021 08:40
1. Определи вид цифрового носителя. USB-жесткий диск карта памяти оптический диск USB-носитель...
НЕЗНАЙКА123987
10.09.2019 03:30
Срешением 4-го варианта. в программе «: =» обозначает оператор присваивания, знаки «+», «-», «*» и «/» — соответственно операции сложения, вычитания, умножения...
shikunovnikitkp00sz1
10.09.2019 03:20
Вычислить функцию y=(x-7)/(x+5) при любом значении x...
TPROfesorT
06.07.2019 14:30
Для чего служит указатель конец цикла ?...
muradveliyev
06.07.2019 14:30
Составить блок схемы, написать программу для вычисления: 1) площади и периметра треугольника. 2) дан радиус окружности. найти длину и площадь окружности. огромное!...
vitalina05062005
30.06.2019 20:50
Для приготовления компота берут 6 частей яблок, 5 частей груш и 3 части слив. сколько нужно взять грушдля приготовления компота, если масса всех фруктов составляет...
Korolev776
30.06.2019 20:50
Решить, ! в арифметической прогрессии третий член равен -6, сумма второго и пятого членов равна -9, n-й член равен 15. найдите номер n....
Популярные вопросы
Установи відповідність між числівниками та їх відмінковою формою1...
2
Установи соответствие у себя в тетради 1.Айтеки би - № ? 1)...
1
Хелп хелп промежутка по алгебре...
3
Напишите отзыв по рассказу Теффи жизнь и вторник по плануКто...
1
Строница 268 упрожнение 494А С кем у вас осациируется День Победы?...
1
Спиши текст, дописывая нужные окончания. У прилагательных укажи...
2
Вычитаемое равно 34 а разность 79 уменьшаемое равно п...
3
Рассчитай, какая масса хлора образовалась при взаимодействии...
3
Решите задачу. Впишите ответ. Касательная KE (E — точка касания)...
2
Мал шаруашылығы қалай дамиды...
1
var
i,n,s:integer;
begin
Write('n='); Read(n);
s:=0;
for i:=1 to n do
if ((i mod 4)=1) or ((i mod 4)=2) then s:=s-i else s:=s+i;
Writeln('Сумма ряда равна ',s)
end.
Тестовое решение:
n=13
Сумма ряда равна -1