tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
+! в одномерном массиве x(15)
+! в одномерном массиве x(15) найти максимальный из элементов, меньше трех, и поменять его местами с предпоследним
Bohdanka999
1 04.07.2019 14:30
1
Ответы
ZHANSAYA20061
28.07.2020 08:17
Const
N = 15;
Var
A:array[1..N]of real;
B:real;
i,j:integer;
Begin
For i:= 1 to N do
Begin
A[i]:=random(15)+2;
Write(A[i],' ')
End;
j:=0;
Repeat
j:=j+1
Until (A[j]<3)or(j=N);
if A[j]>=3 then
Begin
WriteLn;
WriteLn('В массиве нет элементов меньше 3')
End
else Begin
For i:= j to N do
if (A[i]>A[j])and(A[i]<3) then j:=i;
B:=A[j];
A[j]:=A[N-1];
A[N-1]:=B;
WriteLn;
For i:= 1 to N do
Write(A[i],' ')
End
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
kozlovavika200
14.12.2021 15:51
Какой факультатив посещает наибольшее количество учеников? БЫСТРЕЕ,...
Mucuo31
11.03.2021 15:06
3. Напишите программный код, вычисляющий периметр фигуры....
zhekabigboss
11.03.2021 15:03
Напишите, как записывается операция нахождения целой части от деления? Напишите, какой оператор считывает данные с экрана монитора и присваивает их переменной?...
goverdovskay123
29.08.2019 01:00
Дана последовательность целых чисел. замечание. из данного пункта решить двумя используя одномерный массив. размерность массива вводится с клавиатуры. 1. заменить все положительные...
Денис228ннпп
23.01.2021 23:44
Phyton. Решите Пользователей программы в вводит с клавиатуры целое положительное число. напишите программу определяющую является ли это число простым....
тлрп
23.01.2021 23:48
Напишите программу, выводящую 10 первых четных чисел, кратных 11-ти...
Fiza15
23.01.2021 23:51
Выведите последовательность: 10,9,8...-9,10. Числа выводятся через занятую и пробел ( после последнего числа должна стоять точка ). Используйте обратное изменение счётчика...
yarikmazai
23.01.2021 23:56
Phyton! Напишите программу, выводящую все возможные целочисленные комбинации сторон прямоугольника по заданному значению его площади. Каждая пара выводится через пробел...
danilkudo423
23.01.2021 23:56
Информатика на компьютере Напишите программу, выводящую 10 первых четных чисел, кратных 11-ти...
RRE1
23.01.2021 23:58
Переведите код с паскаля на питон...
Популярные вопросы
Пассивный залог. Выберите правильный ответ.1. She has closed the door.The...
2
выразите мнение(письменно)...
3
.Напишіть від імені Шерлока про план розслідування у «Пістрявій стрічці»....
3
В якому рядку всі числівники записано правильно * А.восьмистам дев’яноста...
3
определить типы глаголов: 1. Он был влюблен в неё долго и безнадёжно...
3
Приклади поетичного звертання, пейзажу, окличних речень та повторів у...
3
Тезисы план К.Кулинарные Напишете...
2
Що можна віднести донедоліків ринку? Свобода підприємництва; Високий...
3
Высшая математика, HELP! Теории функций комплексной переменнойНеобходимо...
2
Для упаковки одного подарка требуется 1.1/3м упаковочный бумаги сколько...
1
N = 15;
Var
A:array[1..N]of real;
B:real;
i,j:integer;
Begin
For i:= 1 to N do
Begin
A[i]:=random(15)+2;
Write(A[i],' ')
End;
j:=0;
Repeat
j:=j+1
Until (A[j]<3)or(j=N);
if A[j]>=3 then
Begin
WriteLn;
WriteLn('В массиве нет элементов меньше 3')
End
else Begin
For i:= j to N do
if (A[i]>A[j])and(A[i]<3) then j:=i;
B:=A[j];
A[j]:=A[N-1];
A[N-1]:=B;
WriteLn;
For i:= 1 to N do
Write(A[i],' ')
End
End.