tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Уровень b. напишите программу,
Уровень b. напишите программу, которая сортирует массив и находит количество различных чисел в нем.
akikoaki
3 26.07.2019 08:10
11
Ответы
Luna2904
24.09.2020 20:49
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
var a:=ArrRandom(ReadInteger('n='),10,99);
a.Println.Sorted.Println;
Writeln('Количество разных чисел ',a.Distinct.Count)
end.
Тестовое решение:
n= 20
60 33 12 47 79 81 33 26 73 98 82 81 71 70 96 48 13 66 29 85
12 13 26 29 33 33 47 48 60 66 70 71 73 79 81 81 82 85 96 98
Количество разных чисел 18
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
wenefep07126
06.10.2019 14:40
Написать 2 алгоритма на ая ( из произведения из жизни)...
2345Pomogite2345
06.10.2019 14:40
Вмассиве 20 целых элементов заданных с клавиатуры найти сумму элементов массива кратных семи и оканчивающихся на цифру 1...
Maria2009
06.10.2019 14:40
На бесконечном поле имеется длинная горизонтальная стена. длина стены неизвестна. от нижнего конца стены влево отходит горизонтальная стена также неизвестной длины. робот находится...
NikolaAdamova
06.10.2019 14:40
Напишите программу, которая вводит из файла весовую матрицу графа и строит для него минимальное остовное дерево.паскаль....
alianna366
06.10.2019 14:40
Некоторый алгоритм из одной цепочки символов получает новую цепочку следующим образом. сначала вычисляется длина исходной цепочки символов; если она нечётна, то...
moni9
06.10.2019 14:40
Дана цепочка символов пол.какая цепочка символов проучится,если к данной цепочке применить алгоритм дважды...
Velichkovskaya
06.10.2019 14:40
Как связаны бит байт мегабайт и тд?...
Karina0714
06.10.2019 14:40
Примеры понятий: а) противоположных б) противоречащих...
dreamnazym
06.10.2019 14:40
50 из ниже текста выберите информацию о том, какие семейства входят в отряд парнокопытных. лишнюю информацию удалите. оставшуюся информацию оформите в виде маркированного списка....
serialoman3
06.10.2019 14:50
Разместите на форме ряд кнопок ( button ) напротив каждой поле ввода ( textbox ) и одну метку ( label ) . создайте обработчики события накатия на данные кнопки , которые будут...
Популярные вопросы
Определить число молекул в 50 г сахара c12 h22 o11...
3
1 - topshiriq. Rasm asosida berilgan so zlardan foy- dalanib, gaplar tuzing.Foydalanish...
3
Найдите объем 42 г азота N2 при нормальных условиях (н, у)...
3
(7-x/5x+x^2-x+6/5x+x^2)(20x+23x^2-x^3/23x-5 -x)...
3
Запишите периодисескую десятичную дробь в виде обыкновенной:a) 0,(5); b)...
3
1. a This house is very nice. Does it have ... garden? b It s a beautiful...
1
Складіть план проведення експерименту. Запропонуйье,як підвищити точність...
2
3 и 4 варианты по химии аналогично сори за качество не моя фотка...
3
ответьте по камерной музыке...
2
7 ПРЕДЛОЖЕНИЙ О ГОРОДЕ СМОЛЕНСК ПОБЫСТРЕЕ...
3
begin
var a:=ArrRandom(ReadInteger('n='),10,99);
a.Println.Sorted.Println;
Writeln('Количество разных чисел ',a.Distinct.Count)
end.
Тестовое решение:
n= 20
60 33 12 47 79 81 33 26 73 98 82 81 71 70 96 48 13 66 29 85
12 13 26 29 33 33 47 48 60 66 70 71 73 79 81 81 82 85 96 98
Количество разных чисел 18