Составьте программу поиска трехзначных чисел которые при делении на 43 в остатке 41 а при делении на 47 в остатке 43

Masimo1 Masimo1    3   09.06.2019 04:20    9

Ответы
nataliylitvino nataliylitvino  08.07.2020 01:32
А нет таких чисел!

var
  i:integer;
begin
  for i:=1 to 10000 do  // по условиям задачи i:=1 to 999
    if (i mod 43 = 41) and (i mod 47 = 43) then
      writeln(i);
end.

Результаты вывода:
1030
3051
5072
7093
9114

Так что минимальное число, удовлетворяющее требованиям, 1030, но оно не трехзначное

Вот более продвинутый алгоритм, делающий то же самое:

var
  n43:integer;
begin
  n43:=127;
  repeat
    n43:=n43+43;
  until (n43 mod 43 = 41) and (n43 mod 47 = 43); //добавить and (n43<1000)
  writeln(n43)
end.

Результат вывода:
1030
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика