tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Сожмите линейный массив
Сожмите линейный массив , удалив элементы предшествующие минимальному элементу .
sofiotap3
3 27.06.2019 20:00
18
Ответы
Назмина134
22.07.2020 08:30
Min:=а
k:=1
j:=1
for i:=2 to n do
if a[i]< min then
begin
min:=a[i]
k:=i
end
if k>1 then
for i:=k to n do
begin
a[j]:=a[i]
inc(j)
end
writeln(результат)
for i= 1 to n-k+1 do
write(a[i]:3);шт
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
natakubkina78
21.10.2020 18:29
С какой скоростью передается файл размером 2048 бит, если на это уходит 32 секунды?...
Ilyakuhs228
20.12.2020 14:14
Циклы в Python: 7. Проверить является ли введенное число степенью двойки и, если да, то какой. 8. Перед вами на столе две бутылки. Bottle_1 пустая и имеет объем в 500 мл,...
Хулиганочка13
20.12.2020 14:14
Составить алгоритм в виде блок схемы для вычисления следующего уравнения. S=2+4+6...+236...
Annala1
20.12.2020 14:14
Циклы в Python: 1. Создать последовательность из N чисел. 2. Добавлять в последовательность только четные числа 3. Добавлять в последовательность из N чисел каждое третье...
олжик13
20.12.2020 14:14
у меня сор по информатике у меня идет время аоаоа...
sofiko07161
20.12.2020 14:14
МНОГО !задание на вложенные циклы N-раз. То есть, цикл в цикле. Особое внимание на начальное положение робота и на стены. Рисовать он должен те клетки, которые серым цветом...
Борель
21.03.2019 01:37
Представь десятичное число 10846 в шестнадцатеричной системе счисления! ...
МишкаКочолапый
21.03.2019 01:43
Скодом jquery имею модальное окно и код jquery. как мне сделать, чтоб при клике в модальном окне на да - удалялась ? скрины:...
RitkaRita
21.03.2019 02:40
Составьте программу, которая формирует массив из 20 случайных целых чисел, каждое из которых находится в диапазоне от -15 до 15, и выводит на экран вначале исходные, а затем...
kotikzxp
22.04.2020 15:59
Дано исходное состояние таблицы. После выполнения команды КОПИРОВАТЬ А2:В2 в А3:В5 значения клеток А5 и В5 будут равны соответственн...
Популярные вопросы
Боря вышел из парка, когда Олег на велосипеде отъехал от парка по той...
3
Используя правила построения, изобразите предоюломленный луч (Перерисовать...
2
Твір моральні уроки повісті Гобсек(1,5 - 2 ст) ...
2
Болашақ үрпаққа таза әлем қалдырғымыз келсе не істеуімізге болады...
2
Оптическая сила линзы должна быть- 2,5 диоптрии. Каково фокусное расстояние...
2
Nh4cl+koh дайте химическую характеристику...
1
Есептеулерді программада орындаңдар. 1. 105-ке 5-ті қосыңдар.2. 50-ден...
1
с выполнением двух заданий. Заранее благодарю...
2
Различия рассказов А. Куприна Чудесный доктор и О. Генри Дары Волхвов...
3
Найди первые четыре члена и 10-й член арифметической прогрессии (an),...
3
k:=1
j:=1
for i:=2 to n do
if a[i]< min then
begin
min:=a[i]
k:=i
end
if k>1 then
for i:=k to n do
begin
a[j]:=a[i]
inc(j)
end
writeln(результат)
for i= 1 to n-k+1 do
write(a[i]:3);шт