Составьте программу на языке паскаль для решения . с клавиатуры вводятся 5 действительных чисел. найти сумму всех чисел, больше 5. и произведение всех чисел, меньше 1.

ulyanan260801 ulyanan260801    3   10.09.2019 11:00    2

Ответы
ddddsfvxsf ddddsfvxsf  07.10.2020 05:11
Const n =5;
var
  a: array[1..n] of integer;
  i,k,s,p:integer;
begin
s:=0;
p:=1;
for i:=1 to n do
  begin
  readln(a[i]);
  if(a[i] >= 5) then
      s:=s+a[i] else
  if (a[i] <1) then
      p:=p*a[i];
  end;
 writeln('Исходные числа');
for i:=1 to n do
    write(a[i]+ ' ');
writeln;
writeln('Сумма чисел больше 5 : ',s:2);
writeln('Произведение меньше 1 : ',p:2);
readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика