Составьте программу, которая запрашивает число. Если введено положительное число, то на экран выводится квадрат этого числа. В противном случае выводится сообщение "Ошибка. Введено неправильное число" и повторный запрос на ввод нового числа.

Ыыыап Ыыыап    3   09.11.2021 13:21    1

Ответы
vicroriaalakoz3 vicroriaalakoz3  09.11.2021 13:30

Программа:

Python:

while True:

   n = int(input('Введите число: '))

   if n > 0:

       print(n * n)

       break

   else:

       print('Ошибка. Введено неправильное число')

Pascal:

var

 n: integer;

begin

 while True do begin

   write('n = '); readln(n);

   if n > 0 then begin

     writeln(n * n);

     break

   end

   else writeln('Ошибка. Введено неправильное число');

 end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика