Составить программу вычисления количества натуральных нечётных чисел сумма квадратов которых не превысит 1000.( на паскале)

AkimMen AkimMen    3   21.07.2019 20:50    1

Ответы
karinaletgo07 karinaletgo07  15.09.2020 21:24
//PascalABC.NET (версия 3.1, сборка 1198 от 11.03.2016)
var
  a, s, n: integer;
begin
  while s < 1000 do
  begin
    if a mod 2 <> 0 then begin
      s := s + sqr(a);
      n := n + 1;
    end;
    a := a + 1;
  end;
  writeln(n-1);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика