Написать программу с цикла с постусловием (repeat). паскаль вычислить сумму чисел в диапазоне от 19 до 51, если они делятся на 5.

Боженька206 Боженька206    3   26.06.2019 02:00    7

Ответы
dan5259oxnhwz dan5259oxnhwz  02.10.2020 11:49
Var a,b,c:
integer;
begin
a:=19;
b:=0;
repeat
if (a mod 5 = 0) then
b:=a+b;
a:=a+1;
until (a>52);
writeln(b);
end.
ПОКАЗАТЬ ОТВЕТЫ
elenalenam elenalenam  02.10.2020 11:49
// Pascal
  var sum : integer;
      i: integer;
begin
  sum := 0;
  i := 19;
  repeat
    if i mod 5 = 0 then
      sum := sum + i;
    i := i + 1;
  until (i > 51);
  writeln(sum);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика