Составить программу "Умножить последнюю цифру четырехзначного числа на 10"
на языке паскаль.

енот252 енот252    3   24.02.2021 09:13    39

Ответы
masha2450 masha2450  24.02.2021 09:20

ТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛТЫ Е*ЛАН Я ТЕ ПОДАРИЛ

ПОКАЗАТЬ ОТВЕТЫ
vipmurlyan vipmurlyan  21.01.2024 18:32
Прежде чем перейти к написанию программы на языке Паскаль, давайте разберемся, что требуется сделать в данной задаче.

У нас есть четырехзначное число, и нам нужно умножить его последнюю цифру на 10. Чтобы выполнить это, нам нужно разделить число на 10 и сохранить только остаток от деления. Этот остаток и будет последней цифрой изначального числа. Затем мы умножаем эту цифру на 10 и получаем результат.

Итак, теперь мы можем перейти к написанию программы на языке Паскаль.

```
program MultiplyLastDigitBy10;

var
number, lastDigit, result: integer; // Объявляем переменные числа, последней цифры и результата

begin
write('Введите четырехзначное число: '); // Просим пользователя ввести число
readln(number); // Считываем введенное число

lastDigit := number mod 10; // Вычисляем последнюю цифру с помощью остатка от деления на 10

result := lastDigit * 10; // Умножаем последнюю цифру на 10 и сохраняем результат

writeln('Результат: ', result); // Выводим результат на экран
end.
```

Давайте разберемся, как работает эта программа.

1. Сначала мы объявляем переменные "number" для хранения введенного числа, "lastDigit" для хранения последней цифры и "result" для хранения результата умножения.
2. Затем мы просим пользователя ввести четырехзначное число, используя функцию `write`, и считываем его с помощью функции `readln`.
3. Далее мы используем оператор `mod` для вычисления остатка от деления числа `number` на 10. Остаток равен последней цифре числа.
4. Мы сохраняем последнюю цифру в переменную `lastDigit`.
5. Затем мы умножаем `lastDigit` на 10 и сохраняем результат в переменную `result`.
6. Наконец, мы используем функцию `writeln` для вывода результата на экран.

Теперь мы можем запустить программу и проверить ее работу.

Если пользователь, например, вводит число 1234, то программа выведет результат: "Результат: 40", потому что последняя цифра 4 умножена на 10.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика