Нужно составить программу с repeat,определяющую максимальное из всех введённых вами чисел.(пусть признаком конца ввода чисел является введённое число 0).

Саня200763 Саня200763    2   28.03.2019 08:20    4

Ответы
lmarki2003 lmarki2003  26.05.2020 23:20

var
i, e : Integer;
begin

Writeln('Вводите числа:');

i := 0;

repeat
Readln(e);

if e > i then i := e;
until e = 0;

Writeln('Наибольшее число: ', i);

end.

ПОКАЗАТЬ ОТВЕТЫ
Dhffhjh Dhffhjh  26.05.2020 23:20

Program abc;

uses crt;

const n=30;

var

a:array[1..n] of integer;

i, max:integer;

begin

clrscr; 

for i:=1 to n do

read(a[i]);

max:=a[1];

for i:=2ton do

if a[i]>max then max:=a[i];

write('max=',max);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика