Составить программу нахождения суммы всех делителей заданного натурального числа N.
(Само число и единица включаются в число делителей.)

Формат входных данных
Входной файл содержит число N (N больше или равно 1 и меньше или равно 1000)

Формат выходных данных
Выведите искомую сумму.

Примеры:
Вход
3
Выход
4

kostya2031 kostya2031    1   07.03.2020 02:03    2

Ответы
r79533240813 r79533240813  11.10.2020 20:40

var N,C,D,i: longint;

begin

 assign(input, 'input.txt'); reset(input);

 read(N,C,D);

 C:=C*D;

 for i:=1 to N div C do  

 if N mod (C*i) = 0 then

 write(C*i, ' ');

 writeln();

end.

Объяснение:

но эт не точно

ПОКАЗАТЬ ОТВЕТЫ
КнигаЗнаний16 КнигаЗнаний16  11.10.2020 20:40

var n,i,s:integer;

begin

read(n);

s:=0;

for i:=n downto 1 do

if n mod i = 0 then  s:=s+i;

write(s);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика