Составить программу на паскале дано натуральное число,найти сумму цифр этого числа!

serbakovasvetas serbakovasvetas    2   25.03.2019 08:30    0

Ответы
Юлия20034 Юлия20034  26.05.2020 18:17

Program Program1;
var
i,sum,n,code:integer;
s:string;
begin
write('Введите натуральноее число: ');
readln(s);

sum:=0;
for i := 1 to Length(s) do
begin
Val(s[i], n, code);
sum:=sum + n;
end;
writeln('Сумма цифр: ', sum)
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика