Составить программу на Pascal.
Дан прямоугольник, длины сторон которого a и b представляют собой натуральные числа. Составить рекурсивную программу-функцию, подсчитывающую, на сколько квадратов с натуральными длинами сторон можно разрезать исходный прямоугольник, если каждый раз от него отрезать квадрат максимально возможной площади.​

leda5 leda5    3   07.04.2020 17:28    3

Ответы
olenapolova4 olenapolova4  23.08.2020 19:28

Pascal ABC.

Код:

var

  a, b: integer;

function sko(a, b: integer): integer;

begin

    if (a = b)

    then

        sko := 1

    else begin

         if a < b then

            b := b - a

         else

             a := a - b;

         sko := 1 + sko(a, b);

    end;

end;

begin

    readln(a, b);

    writeln(  sko(a, b)   );

end.

Пример действия:

Ввод:

5 4

Вывод:

5

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика