tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Надо программировать в
Надо программировать в pascal abc,не могу придумать ! : найти количество хорошистов в сельской школе.если известно,что в ней 15 классов.количество хорошистов в каждом классе вводятся с клавиатуры.
palienkoana
2 22.08.2019 02:10
10
Ответы
sitnikova03
05.10.2020 11:34
Program eewtew;
type
Human = class
public
q: integer; // 1 класс
e: integer; // 2 класс
r: integer; // 3 класс
t: integer; // 4 класс
y: integer // 5 класс
u: integer; // 6 класс
i: integer; // 7 класс
o: integer; // 8 класс
p: integer; // 9 класс
a: integer; // 10 класс
s: integer; // 11 класс
d: integer; // 12 класс
f: integer; // 13 класс
g: integer; // 14 класс
j: integer; // 15 класс
end;
var
H: human;
begin
H:= new Human;
writeln('Введите кол-во хорошистов в 1 классе');
readln(h.q);
writeln('Введите кол-во хорошистов в 2 классе');
readln(h.e);
writeln('Введите кол-во хорошистов в 3 классе');
readln(h.r);
writeln('Введите кол-во хорошистов в 4 классе');
readln(h.t);
writeln('Введите кол-во хорошистов в 5 классе');
readln(h.y);
writeln('Введите кол-во хорошистов в 6 классе');
readln(h.u);
writeln('Введите кол-во хорошистов в 7 классе');
readln(h.i);
writeln('Введите кол-во хорошистов в 8 классе');
readln(h.o);
writeln('Введите кол-во хорошистов в 9 классе');
readln(h.p);
writeln('Введите кол-во хорошистов в 10 классе');
readln(h.a);
writeln('Введите кол-во хорошистов в 11 классе');
readln(h.s);
writeln('Введите кол-во хорошистов в 12 классе');
readln(h.d);
writeln('Введите кол-во хорошистов в 13 классе');
readln(h.f);
writeln('Введите кол-во хорошистов в 14 классе');
readln(h.g);
writeln('Введите кол-во хорошистов в 15 классе');
readln(h.j);
writeln('Мы сорали информацию о классах');
writeln('В 1 классе: ', h.q, ' хорошист(а/ов)');
writeln('В 2 классе: ', h.e, ' хорошист(а/ов)');
writeln('В 3 классе: ', h.r, ' хорошист(а/ов)');
writeln('В 4 классе: ', h.t, ' хорошист(а/ов)');
writeln('В 5 классе: ', h.y, ' хорошист(а/ов)');
writeln('В 6 классе: ', h.u, ' хорошист(а/ов)');
writeln('В 7 классе: ', h.i, ' хорошист(а/ов)');
writeln('В 8 классе: ', h.o, ' хорошист(а/ов)');
writeln('В 9 классе: ', h.p, ' хорошист(а/ов)');
writeln('В 10 классе: ', h.a, ' хорошист(а/ов)');
writeln('В 11 классе: ', h.s, ' хорошист(а/ов)');
writeln('В 12 классе: ', h.d, ' хорошист(а/ов)');
writeln('В 13 классе: ', h.f, ' хорошист(а/ов)');
writeln('В 14 классе: ', h.g, ' хорошист(а/ов)');
writeln('В 15 классе: ', h.j, ' хорошист(а/ов)');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Даріна11111111
28.07.2019 10:10
Заполни пропуски в блок-схеме алгоритма для...
gricenkoviktor
28.07.2019 10:20
1. найди лишнее слово и зачеркни. текстовая,графическая,зрительная,числовая....
michytka2305200
28.07.2019 10:20
Проанализируй оркестром и заполни тублицу объект объект цель средство (жесты , оркестр, дирижёр , дирижёрская палочка, музыка: слова для справки)...
Sashka1712
28.07.2019 10:20
1. вставь пропущенные слова. будем называть всё то, на что мы обращаем наше внимание: данные для справки: объект,предмет,явление,действие,событие,процесс,живое существо,растение....
elizaveta4256
28.07.2019 10:30
1. определите количество информации в кбайтах книги, содержащей 128 страниц, на каждой странице 64 строк, в каждой строке 64 знака. 2.определите количество времени в минутах, которое...
Ghdgfhs
28.07.2019 10:30
Как с точки зрения содержательного подхода к измерению информации определяется единица измерения количества информации?...
Silvertrue
28.07.2019 10:30
Что лучше mac os x или windows 10 объясните...
asdfghjkl12347
28.07.2019 10:40
Это ! массив 5 чисел,диапозон от 0 до 20.выстроить числа в массиве в порядке возрастания(отсортировать массив в порядке возрастания)...
aumchik
28.07.2019 10:40
:запиши обратного алгоритма и допиши его команды-почисти ковёр...
Dzjeihunqasanov
28.07.2019 10:40
Что такое презентация для чего она проводится?...
Популярные вопросы
Написать на дорогий захар! що ти робиш в суботу увечері? я буду ідти до піцерії.міг...
3
Скорость автомобиля возросла с 64км/ч до 80км/ч.на сколько процентов возросла скорость?...
3
Написать мини-твір на тему: без праці жити- тільки небо коптити ввести в нього одне...
2
Какая категория должна быть у водителя фуры с прицепом...
2
По какой формуле вычисляют период равномерного движения тела по окружности?...
3
Какой был кактус из сказки attalea princeps...
2
2класс что ты знаешь о жизни птиц зимой в нашей местности...
3
Найти массу оксид меди количеством вещества 0,4 моль...
2
Почему лена бессольцева из повести чучело считала себя предателем? надо 40 ....
2
Жила-была девочка. её звали рита . однажды мама риты попросила сходить за хлебом,...
2
type
Human = class
public
q: integer; // 1 класс
e: integer; // 2 класс
r: integer; // 3 класс
t: integer; // 4 класс
y: integer // 5 класс
u: integer; // 6 класс
i: integer; // 7 класс
o: integer; // 8 класс
p: integer; // 9 класс
a: integer; // 10 класс
s: integer; // 11 класс
d: integer; // 12 класс
f: integer; // 13 класс
g: integer; // 14 класс
j: integer; // 15 класс
end;
var
H: human;
begin
H:= new Human;
writeln('Введите кол-во хорошистов в 1 классе');
readln(h.q);
writeln('Введите кол-во хорошистов в 2 классе');
readln(h.e);
writeln('Введите кол-во хорошистов в 3 классе');
readln(h.r);
writeln('Введите кол-во хорошистов в 4 классе');
readln(h.t);
writeln('Введите кол-во хорошистов в 5 классе');
readln(h.y);
writeln('Введите кол-во хорошистов в 6 классе');
readln(h.u);
writeln('Введите кол-во хорошистов в 7 классе');
readln(h.i);
writeln('Введите кол-во хорошистов в 8 классе');
readln(h.o);
writeln('Введите кол-во хорошистов в 9 классе');
readln(h.p);
writeln('Введите кол-во хорошистов в 10 классе');
readln(h.a);
writeln('Введите кол-во хорошистов в 11 классе');
readln(h.s);
writeln('Введите кол-во хорошистов в 12 классе');
readln(h.d);
writeln('Введите кол-во хорошистов в 13 классе');
readln(h.f);
writeln('Введите кол-во хорошистов в 14 классе');
readln(h.g);
writeln('Введите кол-во хорошистов в 15 классе');
readln(h.j);
writeln('Мы сорали информацию о классах');
writeln('В 1 классе: ', h.q, ' хорошист(а/ов)');
writeln('В 2 классе: ', h.e, ' хорошист(а/ов)');
writeln('В 3 классе: ', h.r, ' хорошист(а/ов)');
writeln('В 4 классе: ', h.t, ' хорошист(а/ов)');
writeln('В 5 классе: ', h.y, ' хорошист(а/ов)');
writeln('В 6 классе: ', h.u, ' хорошист(а/ов)');
writeln('В 7 классе: ', h.i, ' хорошист(а/ов)');
writeln('В 8 классе: ', h.o, ' хорошист(а/ов)');
writeln('В 9 классе: ', h.p, ' хорошист(а/ов)');
writeln('В 10 классе: ', h.a, ' хорошист(а/ов)');
writeln('В 11 классе: ', h.s, ' хорошист(а/ов)');
writeln('В 12 классе: ', h.d, ' хорошист(а/ов)');
writeln('В 13 классе: ', h.f, ' хорошист(а/ов)');
writeln('В 14 классе: ', h.g, ' хорошист(а/ов)');
writeln('В 15 классе: ', h.j, ' хорошист(а/ов)');
end.