Составить программу на нахождение макимального значения в массиве чисел.

мадина488 мадина488    3   20.07.2019 18:50    4

Ответы
Gelua2128 Gelua2128  07.08.2020 20:53
Var
a:array[1..10] of real;
i,na:integer;
max:real;
begin
repeat
      writeln('Введите количество элементов массива меньше 11');
      readln(na);
until (na>0) and(na<=10);
writeln('Введите элементы массива,',na,' штук');
for i:=1 to na do
    begin
    readln(a[i]);
    if i=1 then max:=a[i]
    else
    if (a[i]>max) then max:=a[i];
    end;
writeln('Наибольший элемент массива = ',max);
end.
ПОКАЗАТЬ ОТВЕТЫ
dolloc dolloc  07.08.2020 20:53
Сделано с рандомными числами.
program massiv;  var mas:array [1..10] of real; a:real; i:byte;    begin     a:=0;     for i:=1 to 10 do begin     mas[i]:=random(10)+1;      if a<mas[i] then a:=mas[i];     end;     writeln(a, ' - наибольшее из чисел массива ' );     end.     
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика