tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу, которая
Составить программу, которая заполняет массив, сортирует по убыванию, находит максимум м выводит его до и после сортировки.
lyutaevayulya
3 14.09.2019 19:30
4
Ответы
botiyava
07.10.2020 15:14
// PascalABC.NET 3.3, сборка 1599 от 17.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
a:=a.OrderByDescending(t->t).ToArray; a.Println;
Writeln('Максимум: ',a.First);
end.
Пример
n= 15
22 26 18 -12 44 44 44 50 -30 11 6 8 -22 2 25
50 44 44 44 26 25 22 18 11 8 6 2 -12 -22 -30
Максимум: 50
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
geracim1
20.10.2020 17:48
Контрольная работа бомова информатика 9 класс моделирование и формализация...
PeaceDuck1337
20.10.2020 17:07
1. Приведите примеры официальных документов 2. Перечислите основные параметры документа и текста.3. Покажите на компьютере изменение направления страница4. Покажите на...
trubadurov01
20.10.2020 17:48
4x-3y=2 3x+2y=1 x[-0,2;0,1] шаг 0,1 решить в excel...
pyanoes
20.10.2020 17:48
Тетитор У исполнителя Калькулятор две команды, которым присвоены номера:вычти 1;2 - умножь на 3,5)Первая из них уменьшает введенное число на 1, вторая увеличивает его...
dksusjehdh
23.02.2022 19:20
Дано целое число. Если оно является отрицательным, то вычесть из него 5; в противном случае прибавить к нему 6. Вывести полученное числоблок схему и программу (Паскаль)...
Kira3998
23.02.2022 19:34
Дано два цілих числа А і В.(А В)Знайди суму всіх цілих чисел від А до В. Python,треба створити код...
MrKom1
23.02.2022 19:36
лучший ответ обеспечен , сколько раз выполнится цикл a=8;b=20 while a b :a+=3...
андряков1103
23.02.2022 19:55
Запишіть вираз мовою математики...
milanagorbovsk
25.03.2021 10:45
Як розмістити кнопку на формі в лазарусі?...
nagibala09Никичан
25.03.2021 10:44
Мультимедийную информацию нецелесообразно сохранять на 1)Flash-память2)DVD -RW3)бумажном носители4)CD-ROM...
Популярные вопросы
Найдите значение выражения √18*80*√2*√5...
2
Аннотация к сказке ночь перед рождеством...
1
Нужно написать что значит для меня родной край в моей семьи (московская...
2
Обчислити молекулярну масу і знайти масову частку всіх елементів у...
1
Почему андрий перешёл на сторону врага?...
3
Составить сложное предложение со словами: что, что бы, потому что,...
2
Является ли ребенок собственностью родителей? почему? кратко....
1
Вкакой сказке герои внимательно слушают друг друга?...
3
Тлумачення фразеологізма: незбагненними шляхами....
2
Вычислите наиболее удобным выражения 47×34+34×26-71×34 help...
1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
a:=a.OrderByDescending(t->t).ToArray; a.Println;
Writeln('Максимум: ',a.First);
end.
Пример
n= 15
22 26 18 -12 44 44 44 50 -30 11 6 8 -22 2 25
50 44 44 44 26 25 22 18 11 8 6 2 -12 -22 -30
Максимум: 50