Составить программу, которая выводит n двузначных натуральных чисел (n вводит пользователь), которые делятся на 4. Посчитать сумму и количество этих чисел.

Aleksandr31821 Aleksandr31821    3   13.11.2020 15:48    14

Ответы
valikrulit1234 valikrulit1234  13.12.2020 15:52

#include <stdio.h>

int main()

{

int N;

int temp;

int sum;

printf("Input a number: ");

scanf("%d", &N);

while (N % 4)

{

printf("a number is not divisible by 4!\n");

printf("Enter the number again:\n");

scanf("%d", &N);

}

printf("Input %d numbers from 10 to 99: \n", N);

for (int i = 0; i < N; i++)

{

scanf("d", &temp);

if (temp < 10 || temp > 99) return 0;

sum += temp;

}

printf("sum of numbers: %d\n", sum);

printf("number of numbers: %d\n", N);

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика