Составить программу, которая проверяет правопис "жи", "ши" и выводит количество ошибок и исправленную строку

chernov5 chernov5    3   16.06.2019 22:40    1

Ответы
kopnina kopnina  13.07.2020 18:25
Var
a,count:longint;
s:string;
begin
writeln('введите строку');
count:=0;
read(s);
while pos('жы',s)>0 do 
begin
 inc(count);
 a:=pos('жы',s);
 delete(s,a,2);
 insert('жи',s,a)
end;
while pos('шы',s)>0 do 
begin
 inc(count);
 a:=pos('шы',s);
 delete(s,a,2);
 insert('ши',s,a)
end;
writeln(s);
writeln('всего ошибок: ',count)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика