Составить программу для нахождения количества и суммы всех чисел, оканчивающихся на 4 на промежутке от 1 до 100. в паскале. подробно , чтобы было понятно.
Program aaa; var i,z,sum:integer; begin sum:=0; //сумма чисел z:=0; //счётчик for i:=1 to 100 do if(i mod 10 = 4) then begin //проверка последней цифры, если 4,то прибавляем к счётчику единицу и к сумме число z:=z+1; sum:=sum+i; end; writeln(z,' ',sum); //Выводим ответ end.
var
i,z,sum:integer;
begin
sum:=0; //сумма чисел
z:=0; //счётчик
for i:=1 to 100 do
if(i mod 10 = 4) then begin //проверка последней цифры, если 4,то прибавляем к счётчику единицу и к сумме число
z:=z+1;
sum:=sum+i;
end;
writeln(z,' ',sum); //Выводим ответ
end.