Решить желательно все или хотя бы одну (p.s. программа для программы turbo pascal) 1.написать программу, которая предлагает ввести 3 значное число и находит сумму его цифр. 2. написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321) 3.написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.
1 и 2 работают до макс. значения integer, а не только трехзначные
var i,s:integer;
begin
readln(i);
while i>0 do begin
s:=i mod 10;
i:=i div 10;
end;
writeln(s);
end.
var i:integer;
begin
readln(i);
while i>0 do begin
write(i mod 10);
i:=i div 10;
end;
end.
var a,b,c:integer;
begin
readln(a,b,c);
writeln('Sum=',a+b+c,' Proizvedenie=',a*b*c,' Sr.arifm=',(a+b+c)/3);
end.