Решить задачу поиска наибольшего элемента массива. Массив заполнить случайными числами из диапазона [0,99].
Задача.
Напишите программу, в которой осуществляется формирование целочисленного массива A из десяти элементов, значения которых лежат в диапазоне от 0 до 99, и поиск наибольшего элемента этого массива.

Маринка200711 Маринка200711    1   07.04.2020 00:49    4

Ответы
ulusa4eva ulusa4eva  12.10.2020 19:48

Так как целевой язык не указан и автор вопроса выразил своё безразличие к этому вопросу, то написал пример на С# с использованием возможностей стандартной библиотеки языка.

Код ниже:

using System;

using System.Linq;

using System.Collections.Generic;

namespace Znanium {

public class AnotherOne

{

 public static void Main()

 {

  // Генерация массива

  var rand = new Random(); // Инициализируем рандомайзер

  int[] arr = (from x in Enumerable.Range(0, 10) // Отсчитываем 10 элементов

     select rand.Next(100)) // Генерируем счисло от 0 до 99

     .ToArray(); // Делаем из объекта массив

 

  // Печатаем массив на экран

  Console.WriteLine("Source array:");

  PrintArr(arr);

 

  // Находим максимальный элемент

  int maxEl = arr.Max();

  Console.WriteLine($"Max element is {maxEl}.");

 }

 

 public static void PrintArr(int[] arr) {

  Console.Write("[ ");

  foreach(var el in arr) {

   Console.Write($"{el} ");

  }

  Console.WriteLine("]");

 }

}

}


Решить задачу поиска наибольшего элемента массива. Массив заполнить случайными числами из диапазона
Решить задачу поиска наибольшего элемента массива. Массив заполнить случайными числами из диапазона
ПОКАЗАТЬ ОТВЕТЫ
pierrotsadclown pierrotsadclown  12.10.2020 19:48

#include <iostream>

using namespace std;

#define n 10

int main()

{

   int arr[n], max=0;

   for(int i=0; i<n; i++)

   {

       arr[i] = rand() % 99;

       cout<<arr[i]<<" ";

       if(max < arr[i])

           max = arr[i];

   }

   cout<<endl;

   cout<<"max "<< max<< endl;

   return 0;

}

Объяснение:

С++


Решить задачу поиска наибольшего элемента массива. Массив заполнить случайными числами из диапазона
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика