Решить по информатике составьте программу "угадай" . программа задумывает случайное число в диапозоне от 0 до 99 после каждой попытки играющего угадать число программа выводит на экран одно из сообщений больше , меньше или угадано . на отгадывание числа дается 10 попыток программа завершается при выполнении одного из условий : дан правильный ответ либо все попытки исчерпаны
flag,i,x,y:integer;
begin
x:=Random(0,99);
flag:=0;
for i:=1 to 10 do begin
write('Введите ваше число ');
readln(y);
if (x = y) then begin
flag:=1;
writeln('Дан правильный ответ!');
break
end
else
if (x < y) then
writeln('Попробуйте взять число поменьше')
else
writeln('Попробуйте взять число побольше');
end;
if flag = 0 then writeln('Все попытки исчерпаны');
end.