Написать программу к : дано число. найти сумму и произведение его цифр.

Merlin131 Merlin131    2   20.09.2019 19:00    3

Ответы
iwliliya18 iwliliya18  10.09.2020 12:58
Program n1;
var n,sum,p: integer;
begin
readln(n);
sum:=0;
p:=1;
while n<>0 do
begin
sum:=sum+n mod 10;
p:=p*(n mod 10);
n:= n div 10;
end;
writeln('сумма цифр: ',sum);
write('произведение: ',p);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика