tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Разработать программу
Разработать программу java, меняющую местами первый и последний четный элементы одномерного массива.
311242aaa
2 18.09.2019 08:10
4
Ответы
Anara2017
26.08.2020 22:40
Package main;
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
public class Main {
public static BufferedReader READER = new BufferedReader(new InputStreamReader(System.in));
public static void main(String[] args) throws IOException {
int N = Integer.parseInt(READER.readLine());
int[] array = new int[N];
for(int i = 0; i < array.length; ++i)
array[i] = Integer.parseInt(READER.readLine());
Main.function(array);
for(int i = 0; i < array.length; ++i)
System.out.println(array[i]);
}
public static void function(int[] array) {
int first=0, last=0, temp;
for(int i = 0; i < array.length; ++i)
if(array[i] % 2 == 0) {
first = i;
break;
}
for(int i = array.length - 1; i > 0; --i)
if(array[i] % 2 == 0) {
last = i;
break;
}
temp = array[first];
array[first] = array[last];
array[last] = temp;
}
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
KatyaSy
06.06.2019 23:50
Написать программу, которая проверяет – образуют ли элементы заданного массива возрастающую последовательность....
gigi24
06.06.2019 22:27
Кто-нибудь сможет сделать? 1 в массиве с = {1, 2, -3, 0, -1, -7, -9, 4, 5, -6, 3, 2, 9, 10, -7, -9, -5} найти количество соседств двух положительных элементов и количество...
amina090806
06.06.2019 22:23
Одномерные и многомерные массивы. нужно составить блок-схемы. ! )...
RedBalloon
03.09.2019 10:20
Написать программу на языке программирования высокого уровня с++ вычисляющую количество введенных чисел и максимальный элемент из входного потока. данные ввести с клавиатуры...
petechkapeshko
03.09.2019 10:20
Даны натуральное число , действительная квадратная матрица порядка n. построить последовательность b1, bn из нулей и единиц, в которой bi= 1 тогда и только тогда, когда...
pelmenev777
05.04.2021 07:40
S=100for K in range (11)s = s-5S=? ...
ebanat3
05.04.2021 07:38
Земля вращается вокруг Солнца со скоростью 30 км/с. На сколько километров она продвинется за t секунд. Напечатайте верное решение задачи в Python...
1lёn1
05.04.2021 07:36
Напишите программу определяющие наличие одинаковых цифр в трехзначном числе Python...
DIMAZVER1980
05.04.2021 07:35
Тема «Ссылки» Word Используя изученный материал, заполни таблицу (в рабочей тетради по образцу):Группа элементовНазначениеОглавлениеСноскиСсылки и спискиНазванияПредметный...
ттууппааяя
05.04.2021 07:31
1. Для чего используются ссылки в текстовом документе!...
Популярные вопросы
По провіднику опором 1 кОм тече струм силою 2 мА протягом 1 години....
3
Какие виды искусства вы знаете?а) религиозныеб) пластические или временныев)...
1
Составьте и запишите диалог из 10 реплик на тему ушиб ноги...
2
Fill in the gaps with have to and must in the correct form. 1. It’s...
2
Расставить знаки препинания, начертить схемы предложений.1.Эти букеты...
3
Начерти прямоугольный треугольник ABC так, чтобы ∢C =90°. AC= 19 см...
3
Complete the zero conditional sentences. Use the correct form of the...
3
Конденсатору ёмкостью 6 мкФ сообщили заряд 2 мкКл. Какова энергия заряженного...
2
ОЧЕНЬ На клетчатой бумаге с размером клетки 1х1 угол. Найдите тангес...
1
Запишіть обернену теорему Вієта для даного рівняння і знайдіть його...
1
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
public class Main {
public static BufferedReader READER = new BufferedReader(new InputStreamReader(System.in));
public static void main(String[] args) throws IOException {
int N = Integer.parseInt(READER.readLine());
int[] array = new int[N];
for(int i = 0; i < array.length; ++i)
array[i] = Integer.parseInt(READER.readLine());
Main.function(array);
for(int i = 0; i < array.length; ++i)
System.out.println(array[i]);
}
public static void function(int[] array) {
int first=0, last=0, temp;
for(int i = 0; i < array.length; ++i)
if(array[i] % 2 == 0) {
first = i;
break;
}
for(int i = array.length - 1; i > 0; --i)
if(array[i] % 2 == 0) {
last = i;
break;
}
temp = array[first];
array[first] = array[last];
array[last] = temp;
}
}