Написать программу на языке программирования высокого уровня с++ вычисляющую количество введенных чисел и максимальный элемент из входного потока. данные ввести с клавиатуры и записать во внешний файл на диске. количество введенных чисел не ограничено. признак окончания ввода чисел во входном потоке - число 421. после записи введенных данных в конец файла дописать количество введенных чисел и максимальное введенное число. например, количество введенных чисел - 12, максимальное среди введенных - 345, причем признак окончания ввода - последнее число 421 не учитывать.

RedBalloon RedBalloon    1   03.09.2019 10:20    3

Ответы
Zakhar13371 Zakhar13371  06.10.2020 14:40
#include <iostream>
#include <fstream>

int main()
{
    setlocale(LC_ALL, "RUSSIAN");
    std::ofstream file("file.txt");
    int cr=0;
    int max = 0;
    int count = 0;
    do
    {
        std::cout << "Введите число >> ";
        std::cin >> cr;
        if (cr > max)
            max = cr;
        if(cr!=421)
            file << cr << std::endl;
        count++;
    } while (cr != 421);
    file << "Количество введенных чисел: " << count << std::endl;
    file << "Максимальное введенное число: " << max << std::endl;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика