tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Программирование на си пользователь
Программирование на си пользователь вводит последовательность произвольных чисел.программа должна определить процент положительных, отрицательных и нулевых элементов последовательности.
привет985
3 19.08.2019 10:30
6
Ответы
evozniukk
20.08.2020 11:59
#include <stdio.h>
int main() {
int n,a,pos=0,neg=0,netr=0;
scanf("%d", &n);
for(int i = 0; i < n; i++) {
scanf("%d", &a);
if(a > 0 ) pos++;
else if(a < 0) neg++;
else netr++;
}
pos = pos/n*100;
neg = neg/n*100;
netr = netr/n*100;
printf("+: %d ; -: %d; 0: %d", pos, neg, netr);
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Alexey2005201937
22.05.2020 19:45
Удаление элементов из массива. Задан одномерный массив размера 10. 1 -4 6 56 0 -6 4 23 8 9 Необходимо удалить его третий элемент. 1. Сколько элементов в массиве? 2. Сколько элементов...
Cfhbcbudh
22.05.2020 21:23
опишіть етапи створення сайтів...
122599baikal
22.05.2020 21:24
По анаграммам найти исходное слова .а) днкрпвоои.б)рттинмиуес...
frausadykova20
26.08.2019 07:30
Даны два не ненулевых числа. найти сумму,разность,произведение и частное их модулей....
левецинкking
26.08.2019 07:20
Примеры алгоритмов на различных уроках...
DenisYTYT
26.08.2019 07:20
Музыкальный фрагмент был оцифрован и записан в виде файла без использования сжатия данных. получившийся файл был передан в город а по каналу связи за 75 секунд. затем тот же музыкальный...
ученик1862
26.08.2019 07:20
Напишите программу заполнения массива а[1: 50] числом 1...
Раяна771155
26.08.2019 07:20
Народ, кто разбирается в pascal abs с этими : 1. написать программу, считающее среднее арифметическое цифр числа. 2. написать программу, считающее сумму цифр кратных 3 числа. 2а. написать...
Коля11111111к
26.08.2019 07:20
Составить программу паскаль нахождение произведения квадратов трех натуральных чисел...
natalavorona358
26.08.2019 07:20
Разработать алгоритм решения , представив его в виде блок-схемы; составить программу на алгоритмическом языке turbo pascal; вывести результаты расчетов на печать (дисплей). дана функция,...
Популярные вопросы
Катет прямоугольного треугольника 6 дм,а противолежащий угол 30 градусов .найти...
1
4предложения с деепричастным оборотом из рассказа тарас бульба...
2
Билет в кино стоит 250 р,для студентов предоставляется скидка 35%сколько будут стоить...
2
Эссе на 200 слов на тему: censorship on the internet...
1
Укассира было 30 монет: 10,15 и 20 копеек на сумму 5рублей.докажите,что 20-копеечных...
2
Рассказать о сражениях атаманов,как они сражались,про каждого рассказать,из тараса...
1
Расстояние между пристанями m км катер проплывает за b часов. до следующей пристани...
1
Умоляю зависит ! оцените массу земли, зная ее радиус и ускорение свободного падения...
1
Делитель 65,частное 0,остаток 33. найти делимое....
2
Между тремя школами разделили 552 кг апильсинов причем в одну школу отправили в...
3
int main() {
int n,a,pos=0,neg=0,netr=0;
scanf("%d", &n);
for(int i = 0; i < n; i++) {
scanf("%d", &a);
if(a > 0 ) pos++;
else if(a < 0) neg++;
else netr++;
}
pos = pos/n*100;
neg = neg/n*100;
netr = netr/n*100;
printf("+: %d ; -: %d; 0: %d", pos, neg, netr);
}