Народ, кто разбирается в pascal abs с этими : 1. написать программу, считающее среднее арифметическое цифр числа. 2. написать программу, считающее сумму цифр кратных "3" числа. 2а. написать программу, находящую минимальную цифру в числе. заранее !

Раяна771155 Раяна771155    3   26.08.2019 07:20    3

Ответы
alechka7 alechka7  05.10.2020 20:32
Var
A,S,n:integer;
Begin
WriteLn('Введите целое число');
ReadLn(A);
S:=0;
n:=0;
While A<>0 do
   Begin
   S:=S+A mod 10;
   n:=n+1;
   A:= A div 10
   End;
WriteLn('Sr = ',S/n);
End.

Var
A,S:integer;
Begin
WriteLn('Введите целое число');
ReadLn(A);
S:=0;
While A<>0 do
   Begin
   if (A mod 10) mod 3 = 0 then S:=S+A mod 10;
   A:=A div 10
   End;
WriteLn('S = ',S);
End.

Var
A,m:integer;
Begin
WriteLn('Введите целое число');
ReadLn(A);
m:=9;
While A<>0 do
   Begin
   if A mod 10 < m then m:= A mod 10;
   A:=A div 10
   End;
WriteLn('Min = ',m);
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика