Плесс. на языке паскаля. напишите программу,которая в последовательности натуральных чисел определяет минимальное,оканчивающееся на 2. программа получает числа. признак окончания ввода 0. количество чисел не превышает 1000. введенные числа не превышают 30000. программа должна вывести одно число - минимальное,оканчивающееся на 2,если таких нет,вывести на экран об этом сообщение.

kjhfdklffsjsw kjhfdklffsjsw    3   25.08.2019 07:20    1

Ответы
polinaaaaaaaaaiiii polinaaaaaaaaaiiii  05.10.2020 18:16
Var
A,m:integer;

Begin
m:=32767;
Repeat
Read(A);
if (A mod 10 = 2)and(A < m) then m:=A;
Until A=0;

if m mod 2 = 0 then WriteLn(m)
else WriteLn('Чисел, оканчивающихся двойкой нет.')
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика

Популярные вопросы