Паскаль. составить программу введённого пользователем числа(целое или нет; положительное, отрицательное или нуль; чётное или нечётное)

МагистрЕдаа МагистрЕдаа    1   28.03.2019 07:40    1

Ответы
vikavika1417 vikavika1417  26.05.2020 22:54

var a: real;
begin
read(a);
if (a mod 2=0) and(a<>0) then write('четное');
if (a mod 2=0) and(a<>0) then write('не четное');
if a=0 then write('нуль');
if a>0 then write('положительное');
if a<0 then write('отрицательное');
if a=0 then write('нуль');
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика