Решать в pascal найти наибольший элемент заданной целочисленной числовой последовательности. входные данные: во входном потоке в первой строке задано натуральное число n (n < = 1000) - количество элементов числовой последовательности. во второй строке через пробел перечислены значения элементов последовательности ai (-32000 < = ai < = 32000). выходные данные: в выходной поток вывести единственное целое число. пример входного файла (input.txt): 8 100 10 -10 -100 300 32000 20000 -30000 пример выходного файла (output.txt): 32000 мое решение(ошибку скажите): var a,b,max,i: longint; begin read(a); for i: =1 to a do begin read(b); if b> =max then max: =b; end; write(max); end.

dashbrazhik dashbrazhik    1   23.09.2019 22:40    2

Ответы
angelinaann angelinaann  08.10.2020 13:31
Ошибка заключается в том, что переменную max нужно инициализировать прежде, чем будет осуществлен вход в цикл.

var a, b, max, i : longint;
begin
  read(a);
  max := -32001;
  for i:=1 to a do begin
  read(b);
  if b >= max then 
    max:=b;
  end;
  write(max);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика