Необходимо написать программу используя оператор выбора case. формулировка: составить программу, которая по введенной с клавиатуры буквы (p,k,t) будем высчитывать площади прямоугольника, квадрата и треугольника соответственно. попробовал решить самостоятельно: program hw; uses crt; var x,y: integer; { длинна и ширина прямоугольника } a,b: integer; { основание и высота треугольника } d: integer; { длина стороны квадрата } rez: real; { результат } ploshad: real; { площадь } p: real; { прямоугольник } k: real; { квадрат } t: real; { треугольник } begin write ('если вы желаете вычеслить площадь прямоугольника, введите его длину и ширину, если же нет, оставьте это поле пустым: '); readln (x,y); write ('если вы желаете вычеслить площадь квадрата, введите длину его стороны, если же нет, оставьте это поле пустым: '); readln (d); write ('если вы желаете вычеслить площадь треугольника, введите его основание, а затем высоту, если же нет, оставьте это поле пустым: '); readln (a,b); write ('укажите букву площади которую хотите вычеслить: прямоугольника(p),квадрата(k) или же треугольника(t) - '); readln (ploshad); case ploshad of p: rez: =x*y; k: rez: =d*d; t: rez: =0.5*a*b; else write ('извините, вы ввели не верный символ.'); end; begin writeln ('результат = ',rez: 100: 3); end; end. но, при запуске программы в строке "case ploshad of" выдает ошибку, что "ожидался порядковый или строковый тип". как исправить?

tokmachevasvp01bjy tokmachevasvp01bjy    1   26.06.2019 23:00    7

Ответы
cabinamaksarov cabinamaksarov  02.10.2020 12:30
Исправил решение. Теперь все работает как нужно. код программы в файле.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика