Напишите программу сложения двух простых дробей (без сокращения дроби). с клавиатуры вводятся значения 4 переменных: числитель и знаменатель первой дроби и числитель и знаменатель второй дроби. на экран выводится 2 числа: числитель полученной дроби и знаменатель.

drmkhva drmkhva    1   07.10.2019 02:30    6

Ответы
dariamaniakova dariamaniakova  10.10.2020 00:47

Paskal ABC

uses CRT;


var a, b, c, d, e, f:integer;


begin


readln(a, b, c, d);


e:=(d*a)+(c*b);

f:=b*d

writeln(e,' ', f);

end.

ПОКАЗАТЬ ОТВЕТЫ
Lesia3081984 Lesia3081984  10.10.2020 00:47

var a,b,c,d:real;

   c1, c2, z1, z2:real;

begin

 write('Введи числитель первой дроби: '); read(a);

 write('Введи знаменатель первой дроби: '); read(b);

 write('Введи числитель второй дроби: '); read(c);

 write('Введи знаменатель второй дроби: '); read(d);

 write(a + ' / ' + b + ' + ' + c + ' / ' + d + ' = ');

 if(b = d) then begin

   c1 := a + c;

   write(c1 + ' / ' + b);

 End else Begin

   z1 := b * d;

   c1 := (z1 / b) * a;

   c2 := (z1 / d) * c;

   z2 := c1 + c2;

   write(z2 + ' / ' + z1);

 end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика