Напишите программу в турбо паскале введите с клавиатуры переменные c и d. если 0

NasteonaSlasteona NasteonaSlasteona    3   06.07.2019 14:00    7

Ответы
natashenkagrekova357 natashenkagrekova357  29.07.2020 18:40
Uses Graph; { Подключаем модуль }
var
  c,d,Gd,Gm:integer;
  k:real;
begin
  Writeln('10<=c<=460; 10<=d<=230');
  Write('Задайте c в пределах от 10 до 460: ');Read(c);
  if (c<10) or (c>460) then Writeln('Неверное значение!')
  else begin
    Write('Задайте d в пределах от 10 до 230: '); Readln(d);
    if (d<10) or (d>230) then Writeln('Неверное значение!')
    else begin
      Gd := Detect;
      InitGraph(Gd, Gm, 'Y:\tp7\bgi'); { Инициализируем графический режим }
      SetColor(4);
      k:=GetMaxX/GetMaxY; { Коэффициент искажений по осям }
      if c<d then Rectangle(Trunc(10/k),10,Trunc((2*d+10)/k),2*d+10)
      else Line(Trunc(c/k),c,Trunc(d/k),d);
      Readln;
      CloseGraph
    end
  end
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика